GraphExpert Professional 1.5.5 documentation

Saving Data

Introduction

After performing some analysis, a typical task is to write data, in some form, to disk for later retrieval. GraphExpert Professional supports several ways to transfer data and graphs to a file or the clipboard.

Writing a GraphExpert Professional (GXP) file

If you want to save all of your components, graphs, and notes to disk, you can choose File->Save or File->Save As in order to write a GXP file to disk. These files can be read in later using File->Open, obviously. GXP files are portable across platforms (Windows, Mac, Linux), so that you can seamlessly read a file on Windows that was created on a Mac, for example. GXP files save all possible information about your current session.

Exporting a dataset to text file

To save your dataset into a text file, right click the desired dataset component, and choose Export. The dataset will be exported using the default delimiter chosen in Edit->Preferences->General->Default delimiter.

Writing a graph to a picture file

To save a particular graph to a file, right click it and select Save. Any graph can be saved wherever it appears via this procedure. Alternatively, click the Save icon in the graph toolbar (if present). See Saving graphs for more details on supported file formats.

A graph can also be copied to the clipboard by right clicking and selecting Copy.

Printing

All graphs in the Graphs pane can be printed by choosing File->Print or File->Print Preview. To print an individual graph, right click it and select Print or Print Preview.

If the margins or paper orientation is not correct, these can be set in the File->Page Setup dialog.