GraphExpert Professional 1.5.5 documentation

Application Preferences

Introduction

Application preferences can be changed by choosing Edit->Preferences from the menu.

General Preferences

_images/prefs-general.png

General settings apply to general items of interest in GraphExpert Professional.

Show Tips at Startup

When the software starts, a helpful tip can be shown. However, if you find this either unhelpful or annoying, it may be turned off (or back on) by selecting this checkbox.

Automatically send issue reports

GraphExpert Professional has the ability to automatically send an issue report should something go wrong with the software. The objective of doing is to find and correct problems in the most timely manner possible.

An issue report, when and if one is sent, contains no personally identifying information or any of your data, and the report itself is submitted anonymously. However, if you would like to opt-out of this behavior, uncheck this box.

Spreadsheet Formatting

The spreadsheet formatting setting allows you to set your preference for how data is displayed, by default, in the spreadsheet. The data may be displayed in a fixed point, scientific, or engineering format, with a precision (number of digits after the decimal) as specified in the with precision field. This default number formatting can always be overridden on a per-cell basis by selecting the cells in the spreadsheet, right clicking, and selecting Format Numbers as documented in Number Formatting.

The engineering format is the same as scientific, except that the exponent is always a multiple of three.

Excel style cursor movement in spreadsheet

By default, both the TAB and ENTER keys are treated as carraige returns in GraphExpert Professional. In other words, the cursor is moved to the left until it bumps into the right side of the dataset, in which case the cursor is moved to the beginning of the next row.

If you would rather that the cursor go right on a TAB (which is the same as the default TAB behavior), and down on an ENTER, select this box. Note that GraphExpert Professional will still keep your cursor within the bounds of the dataset.

Sort Data On File Import

Normally, GraphExpert Professional reads your data directly from file, accounts for the settings in the File Import window while importing, and places it in the spreadsheet. If you would also like to automatically sort the data against the first column, check this box.

This capability is most useful if you frequently use splines to fit data; the data must be sorted for a spline to compute correctly.

Import multicolumn datasets as

When a dataset with more than two columns is imported, it can be, by default, treated as a single dataset (many independent variables, one dependent variable) or a multi dataset (many independent variables, many dependent variables). Note that if treated as a multi dataset, GraphExpert Professional has no choice but to guess that there is one independent variable in the first column, and the rest of the columns are dependent variables. Conversely, if a single dataset is chosen here, GraphExpert Professional guesses that the dependent variable is in the last column, and the rest of the columns comprise the independent variables. Here, just choose the option that matches your workflow in most circumstances.

Default delimiter

In several places in the software, a delimiter is used to separate items in the same row. For example, in copying data to the clipoboard, or in generating a table, a delimiter between data items must be selected. If you have a favorite delimiter, set it here.

Data file location

Default directory where data files are stored. Initially, the data file location is set to $DOCUMENTS/GraphExpert Professional, and some example data and example documents are placed there at install time.

Graphing Preferences

_images/prefs-graphing.png

Max display points

Sets the maximum number of points, per series, to display when drawing a discrete dataset on a graph. If the dataset has more points than this, it will be thinned to this number of points. The thinning is based on an appropriate stride to use in order to reduce the total number of points drawn to below the threshhold given here. This option is in place to prevent extremely slow graph redraws due to attempting to draw an excessive number of points.

This option affects discrete datasets only; not continuous functions. For continuous functions, the Resolution parameter, in the Series Page of the Graph Properties dialog (see Changing Graph Properties), is the way to control the sampling of the function that is used for drawing.

Autoscale when dataset or function added

When a dataset or function is added to a graph (via a Send to Plot command or a drag and drop), GraphExpert Professional can automatically autoscale the graph. In this case, you can set the preference to “Never” or “Always”. If the autoscale lock has been set for a graph (see Graph Toolbar), the graph will not be autoscaled regardless of this setting; in other words, the graph’s autoscale lock takes precedence over this preference.

Autoscale when dataset or function changed

In order to keep the data in view at all times in all graphs, GraphExpert Professional can automatically autoscale the graphs when a dataset or function that is plotted on that graph changes. The disadvantage of doing this is that, for large datasets, the redraw can be slow. Also, if you have specified your own limits to axes in the graphs, they would be lost if the data changes. If the autoscale lock has been set for a graph (see Graph Toolbar), the graph will not be autoscaled regardless of this setting; in other words, the graph’s autoscale lock takes precedence over this preference.

To control when autoscaling takes place, select either “Never” or “Always”.

Autoscale when dataset or function removed

When a dataset or function is removed from a graph (either by removing the result from your document altogether, or by right clicking a result on a plot and selecting “Remove”), GraphExpert Professional can automatically autoscale the graph. In this case, you can set the preference to “Never” or “Always”. If the autoscale lock has been set for a graph (see Graph Toolbar), the graph will not be autoscaled regardless of this setting; in other words, the graph’s autoscale lock takes precedence over this preference.

Middle mouse button for graph properties

Normally, the right mouse button is used to access the context menu on graphs. However, for mouse rotation of 3D graphs, it is sometimes more intuitive to use the right button for that purpose. So, you can set the middle mouse to be the graph context menu activator if desired.

For 2D plots, this setting has no effect. The graph context menu can always be accessed with either a middle or right click of the mouse.

Highlight pickable objects

As you move the mouse over a curve or data, it will highlight, signifying that you can click it to modify its properties. Also, it signifies that, on right-click, you can access the details for that series. However, the redrawing necessary for this feature can make the graph response sluggish. So, deactivate this feature if you don’t need to see the highlighting or access details directly from the graph.

Continuous redraw during pan

During a pan, all continuous series must be regenerated on-the-fly if this feature is turned on. This can be expensive, so if it is OK not to see the curve dynamically update during a pan, turn this checkbox off. The series will then only be regenerated each time the mouse button is released during a panning operation.

As a reminder, this setting does not affect discrete datasets on the graph; only results that are continuous.

Preserve aspect ratio when printing

Normally, any graph is fit to the page when it is printed. If you would like to preserve the aspect ratio of your graph when printing, check this box. In other words, if you have a graph that is long and skinny, to keep it long and skinny when printed, check this box.

Sync legend labels with component names

This option controls how the legend in a plot behaves when its associated component name is changed. For convenience, GraphExpert Professional updates the legend name to match the component name. This way, when you rename a component in the Components pane, all graphs that are displaying that component are automatically updated.

To disable this default behavior, uncheck this box.

Global mathtext font

The font used to render equations (see Mathtext) through the application can be set to Computer Modern, STIX Serif, or STIX Sans-serif. Computer Modern looks very much like TeX equations. STIX Serif looks slightly different, and is meant to blend with surrounding text that is serifed (such as Times Roman). STIX Sans-serif is obviously a non-serifed font, meant to blend with surrounding text that is nonserifed (such as Helvetica or Arial).

Default graph theme

A graph theme is the “look” of the graph, and new themes can be constructed either with the graph theme manager (Tools->Manage Graph Themes) or by saving a theme directly from a graph by right-clicking and selecting Save Theme. Every graph has a default theme, and you can set what that default theme is here. This way, all plots will be constructed with the look that you desire.

Logging Preferences

_images/prefs-logging.png

Log detail

GraphExpert Professional keeps a log in $HOME/.graphexpert/logs (see Log Viewer) ; the log detail setting determines the detail of messages that are stored in the log. The default setting is “info”, which logs all messages that appear in the message window, as well as internal information generated by the application. To have less information logged, move the log detail setting to warning, error, or critical. To log more (for example, if trying to sort out a software problem), move the log detail setting to debug.

Note that the logs are easily viewable by selecting Tools->Log Viewer in the main menu.

Number of log rotations

When the log reaches a maximum size (configurable below), it will be rotated. This means that if the log file in question is main.log, it will be renamed to main.log.1, and all of the other previously rotated log files will be renamed from main.log.1 to main.log.2, and so on. The number of log rotations determines how many of these files you would like to keep. A number of log rotations of three means that you plan to keep main.log, main.log.1, main.log.2, and main.log.3.

Maximum log file size

Choose the largest file size (in megabytes) that any log file will be allowed to reach before rotation. The maximum size on disk that can be taken by the collection of log files is therefore

space(MB) = s_{max} (n_{rotations}+1)

With the default settings of a 2MB log size and 3 rotations, the maximum amount of disk space consumed by the logs is then 8MB.

Localization Preferences

_images/prefs-localization.png

The localization preferences are documented in the Localization chapter, in the Configuring GraphExpert Professional to match your workflow section.

Advanced Preferences

_images/prefs-advanced.png

Number of undo levels

Any undo mechanism consumes some memory to save the previous state of the application; the number of undo levels setting allows you to customize how many previous states are saved that you can undo to. The parts of GraphExpert Professional that support Undo operations are the graphs, data spreadsheets, notes, and messages.

Cache location

The location of a cache that GraphExpert Professional uses. It is not changeable, but it can be cleared if need be. This cache operates very similarly to a web browser’s cache. Clearing it will not affect the correct operation of the program, but will force the regeneration of the information that was cached, slowing performance temporarily.

Always refresh graph themes

If set, this option will merge the graph themes from those available with the software (called the stock themes), to the user’s private theme directory ($HOME/.graphexpert/graph_themes). This happens whenever GraphExpert Professional starts. The purpose of keeping this option selected is that, when GraphExpert Professional is updated/reinstalled, the user will not get any new themes or updated themes that are shipped with the software. In most cases, merging the stock themes alongside your custom themes in $HOME/.graphexpert/graph_themes is the desired behavior.

It should be noted, however, that if you have deleted any of the stock themes, they will reappear. Also, if you have saved modified themes with the same name as the stock themes (which is not recommended), those themes will be overwritten.

If the behavior noted above is not desirable, uncheck this option. It should be remembered, though, that if left unset, the themes will not be updated when any new version of GraphExpert Professional is installed; the themes in the $HOME/.graphexpert/graph_themes folder will be left untouched.

Proxy settings

GraphExpert Professional uses Internet access to begin your trial period (see Installation and Activation), check for latest versions, upload issue reports (if enabled, see Automatically send issue reports), and upload logs (see Log Viewer). If you are using a nonauthenticating proxy or no proxy at all, you can leave Use authenticating proxy for Internet access unchecked, as your proxy settings will be automatically detected.

However, if you are behind a proxy that requires authentication, please fill in the host, port, username, and password for access through the proxy.