GraphExpert Professional 1.5.5 documentation

Localization

Executive Summary

If you live in a locale that uses dots for decimals (such as the US or UK) and you never (or very rarely) read files that use European-style commas-for-decimals, the issues in this chapter are of no interest to you.

If you live in a locale that uses commas for decimals, and you want to see commas throughout the application, select Use region settings in the application preferences. Further, if you need to read files that use the dot-decimal notation most often, select “English” for File I/O numeric format.

If you live in a locale that uses commas for decimals, and you do not want to see commas throughout the application, unselect Use region settings in the application preferences. Further, if you need to read files that use the comma-decimal notation most often, select “European” for “File I/O numeric format”. Also, if you want to be able to cut/paste to/from Excel, which obeys locale settings, select “European” for Clipboard I/O numeric format.

Configuring GraphExpert Professional to match your workflow

Use region settings

The main “switch” is in Edit->Preferences->Localization->Use region settings. If this is checked, GraphExpert Professional uses the region settings as given by the operating system. Any display of a number uses your localized representation, which means that if you live in a locale that uses commas for decimals, all numbers that appear in the spreadsheet, results, etc. use commas. Copying to clipboard uses commas, pasting from clipboard expects commas, writing to files (file export, tables) uses commas, the reading from files expects commas. In other words, the application respects the locale completely.

If Use region settings is left unchecked, the “C” locale is used, which always uses dots for decimals. You are still free to modify the File I/O and Clipboard I/O settings below to match your workflow.

File I/O numeric format

The Edit->Preferences->Localization->File I/O numeric format choice allows you to override the application-wide locale setting for file input/output, to explicitly define the numeric format for reading and writing files. This affects the file import dialog as well as File->Export, With this setting, for example, users that utilize commas for decimals in GraphExpert Professional can choose to read and write files using dots for decimals. And vice versa.

Note

In the file import dialog (see Importing from file), there is still a chance to change the numeric format before reading the file. This setting simply sets the default numeric format in that dialog appropriately.

Clipboard I/O numeric format

The Edit->Preferences->Localization->Clipboard I/O numeric format choice allows you to override the application-wide locale setting for clipboard input/output, to explicitly define the numeric format for copying and pasting. This affects the copy/paste in the spreadsheet, as well as copying numeric data out any window that might offer it. With this setting, for example, users that utilize commas for decimals in GraphExpert Professional can choose to copy and paste data to/from the clipboard using dots for decimals. And vice versa.

File Import: numeric format

In the file import dialog (File->Open), there is a switch to explicitly pick the numerical formatting (English or European style) before reading the file. This gives the user the opportunity, on a file-by-file basis, to specify the numerical format. See Importing from file.

File overrides

If your file contains the following within the first ten lines of the file:

#DataFileProperties: locale=EN

or:

#DataFileProperties: locale=EURO

this signals to the GraphExpert Professional file importing mechanism that the the file uses English or European numerical formatting (as appropriate), and the default there (see Importing from file) will be set appropriately. The user may still override the default, however, but in most cases this would be a bad idea, because the file itself is stating what the correct locale is.

So, you can use this capability in your own data files if you like. All of the sample data files shipped with GraphExpert Professional contain this line, so that the samples work straightforwardly regardless of the application’s current region settings. This small addition to a text datafile lets the file itself express its own numerical formatting.

GraphExpert Professional files

GraphExpert Professional files (.gxp) are not affected by region settings; therefore, they are portable across localities as well as being portable across platforms (Windows, Mac, Linux).