CurveExpert Professional 2.6.5 documentation

Writing Data

Introduction

After performing some analysis, a typical task is to write data, in some form, to disk for later retrieval. CurveExpert Professional supports several ways to extract data and graphs to a file or the clipboard.

Writing a CurveExpert (CXP) file

If you want to save all of your data, results, graphs, and notes to disk, you can choose File->Save or File->Save As in order to write a CXP file to disk. These files can be read in later using File->Open, obviously. CXP files are portable across platforms (Windows, Mac, Linux) and save all possible information about your current session. CXP files are also interchangeable between CurveExpert Professional and CurveExpert Basic.

Also, if a particular model or function is saved as a result in a CXP file and it is not present on the system reading the file, the model/function will automatically be created (on the system reading the file) on your behalf. This newly created model/function will then be available for use in the “Imported” family, and will appear appropriately in the Nonlinear model or function pickers.

Exporting a dataset to text file

To save your dataset into a text file, choose File->Export. The dataset will be exported using the default delimiter chosen in Edit->Preferences->General->Default delimiter.

Writing a graph to a picture file

To save a particular graph to a file, right click it and select Save. Any graph can be saved wherever it appears via this procedure. Alternatively, click the Save icon in the graph toolbar (if present). See Saving graphs for more details on supported file formats.

The same graph can be copied to the clipboard by right clicking and selecting Copy.

Printing

All graphs in the Graphs and Data pane can be printed by choosing File->Print or File->Print Preview. To print an individual graph, right click it and select Print or Print Preview.

If the margins or paper orientation is not correct, you can set these in the File->Page Setup dialog.