CurveExpert Professional 2.6.5 documentation

Miscellaneous

Log Viewer

To view the log files, select Tools->View Logs from the main menu. All logs are stored in the $HOME/.curveexpert/logs directory, and roll according to the preferences that you have set in Edit->Preferences->Logging (see Logging Preferences). So, you can easily view logs for previous sessions of CurveExpert Professional with this tool.

To copy a portion of the log, select the desired portion, and press the Copy button. Likewise, to upload a portion of the log to the CurveExpert Professional server (http://www.curveexpert.net), press the Upload button. Uploading of a log is typically used in conjunction with reporting or tracing a software issue. If no part of the log is selected, the entire log will be copied to clipboard or uploaded, as appropriate.

There is one log file per process that CurveExpert Professional runs. If you are using multicore capability (CurveExpert Pro only), there will be several log files (named worker.n, where n is a number from 0 to the number of helper processes minus one) in addition to the main log file. These worker log files document the actions that each worker has performed, and can be copied or uploaded in identical fashion to the main log.

See Logging Preferences for more detail on configuring the logging options.

_images/logviewer.png

Running Multiple Instances

Running multiple instances of CurveExpert Professional is supported; the only side effect is that, because all instances share the same log files, logging might not function properly.

Where files are located

CurveExpert Professional places files in several locations on disk; the locations are documented below.

Program Files

The default locations are listed below, assuming that the default is accepted during the installation process. If you have changed the location of the program files, obviously they will be placed where you specified.

Platform Program Files Location
Windows (64 bit) c:\Program Files (x86)\CurveExpert Professional
Windows (32 bit) c:\Program Files\CurveExpert Professional
Mac (OSX) /Applications/CurveExpertPro.app
Linux (installed as user) $HOME/CurveExpertPro
Linux (installed as root) /usr/local/CurveExpertPro

Application Settings

Platform Application Settings Location
Windows in registry: HKEY_CURRENT_USER\Software\CurveExpert Professional
Mac (OSX) $HOME/Library/Preferences/CurveExpert Professional Preferences
Linux $HOME/.CurveExpert Professional

Working/Cache Area

An area is reserved for various caches and items that are needed for normal application operation. This area is used for the cache, logs, storage of graph themes, and storage of custom user models/functions.

Platform Working/Cache Area Location
Windows $HOME\.curveexpert
Mac (OSX) $HOME/.curveexpert
Linux $HOME/.curveexpert

CurveExpert Professional Data Files

The data files directory can be customized using Edit->Preferences->General, but the default locations are below. This directory is also where the example data that ships with CurveExpert resides.

Platform Documents Location
Windows $MYDOCUMENTS\CurveExpert Professional
Mac (OSX) $HOME/Documents/CurveExpert Professional
Linux $HOME/Documents/CurveExpert Professional