CurveExpert Professional 2.6.5 documentation

Installation and Activation

Installation

Windows

To install on Windows platforms, simply run the installer, either from the command line or by double clicking it in the Windows explorer. The automated installer will start and guide you through the installation process; just follow the on-screen prompts. CurveExpert Professional will install for all users (if you are the Administrator), or for you only (if you are not). This allows you to install CurveExpert Professional without any Administrator privileges.

Windows automated installs

The installer for Windows operating systems recognizes two command line switches: /S for silent installs, and /D=dirname to specify where the program should be installed. For example, in an environment where a system administrator would want to install the program silently to the directory “d:\sharedprogs”, one would do:

> CurveExpertPro-2.6.4-win64.exe /S /D=d:\sharedprogs

Windows automated uninstalls

The uninstaller for Windows operating systems can be used for silent uninstalls. If the software was installed in the directory “c:\sharedprogs”, one would do:

> "c:\sharedprogs\CurveExpert Professional\uninstall" /S
Note that there are no quotes used in the last _? option, even if there are spaces in the path... index::
single: mac single: osx

Mac/OSX

To install on an Apple Macintosh, double click the downloaded .zip archive. If this file is in your Downloads folder, the installation process will start immediately. Otherwise, a .pkg file will be created. In that case, run the .pkg file by double clicking it, and the installation process will then start. Then, follow the on-screen prompts to complete your installation.

CurveExpert Professional is not an Apple-signed application. Therefore, Gatekeeper (if you have OSX Mountain Lion or later) will complain about this fact. This behavior is normal, and it is safe to ignore the complaints from Gatekeeper.

Linux

CurveExpert Professional is a 64-bit application (for 32-bit users, see the note below). To install on a Linux machine, first download the .run file from the CurveExpert Professional web site. Usually, this file will not download with the correct permissions to be run directly. So, give the file execute permissions and then run the downloaded package directly from the command line:

% chmod +x CurveExpertPro-2.5.3-Linux-x86_64.run
% ./CurveExpertPro-2.5.3-Linux.run

Alternatively, you can double-click the downloaded .run file in your file manager, but before you do this, you must give the file execute permissions by right clicking on the file, selecting Permissions, and checking Give file executable permissions (or Allow executing file as program) before you can run the file directly from the file manager.

Note

CurveExpert Professional is also still available as a 32-bit application for legacy users. If you have a 32-bit version, this requires 32-bit libraries to be installed, and in some cases, the 32-bit libraries must be present even before the CurveExpert Professional installation process. If you are running a pure 64-bit Linux installation, you will likely have to install your distribution’s 32-bit compatibility libraries. Usually, you can install the 32-bit version of zlib, gtk libraries, and standard c++ library, and that will be enough (on Debian/Ubuntu distributions, this is packages: ia32-libs-gtk, lib32z1, and lib32stdc++6).

Then, follow the on-screen prompts to complete your installation.

CurveExpert Professional has been tested on the following Linux distributions. If a particular distribution is not listed, that does not necessarily mean that the application will not run properly; as long as the distribution is reasonably recent, the software should work with no problems.

  • SuSe 11.0 [WORKS]
  • SuSe 11.1 [WORKS]
  • SuSe 11.2 [WORKS]
  • SuSe 11.3 [WORKS]
  • SuSe 11.4 [WORKS]
  • Kubuntu 10.04 [WORKS]
  • Kubuntu 10.10 [WORKS]
  • Kubuntu 8.10 [WORKS]
  • Ubuntu 10.10 [WORKS]
  • Ubuntu 12.10 [WORKS]
  • Xubuntu 12.10 [WORKS]
  • Fedora 13 [WORKS]
  • Fedora 14 [WORKS]
  • CentOS 5.0 [FAILED: libc version is too old: 2.7 required]
  • CentOS 5.5 [FAILED: libc version is too old: 2.7 required]
  • Mandriva 2010 Spring [WORKS]
  • Linux Mint Debian 6 [WORKS]
  • Debian 6 [WORKS]

In the Linux arena, there are two primary desktop systems: GNOME and KDE. CurveExpert Professional integrates well with GNOME, offering a desktop icon, appropriate menu entries and icons, file association between .cxp files, and icons for .cxp files. Under KDE, desktop integration is not fully developed. Desktop icons and menu entries are created, but the icons for these do not yet work. File association also works, but the icons for .cxp files are not yet functional.

To run the software from the command line, run the cepro.sh script. For example, if CurveExpert Professional was installed in your home directory, the command would be:

~/CurveExpertPro/cepro.sh

Starting a Trial

If you want to evaluate CurveExpert Professional on a trial basis, you can start a trial period by selecting Help->Activate Trial Period; note that an Internet connection is required for the starting of the trial period, but is not required once the trial period has been activated.

Note

If you use an authenticating proxy for Internet access, please set the appropriate proxy settings in Edit->Preferences->Advanced (see Proxy settings).

This trial period is active for approximately 30 days from activation date. During this period, all features of CurveExpert Professional are accessible. When the software is out of its trial period (either before or after), most output functions are disabled, and a watermark appears on all graphs.

After evaluation via the trial period, please consider purchasing the software at http://www.curveexpert.net/order.

Purchasing

To purchase CurveExpert Professional, visit http://www.curveexpert.net/order, and choose the product that you would like to purchase.

After Purchase: licensing

If you have purchased a CurveExpert Professional license, you will receive the license information via email. Licenses are fulfilled within 24 hours of receipt; average turnaround time between purchase and license fulfillment is 2 hours.

Proceed to Help->Enter License, and paste the entire email into the box. The fields below the box (Name, Company, etc.) will update, and you can then press OK to complete the process.

If you are not sure how to copy and paste the email, highlight the text of the email with your mouse (click and drag), and press Ctrl+C (Cmd+C on a Macintosh). Then, just press the Paste button in the Help->Enter License window.

Thank you for your support of CurveExpert Professional!

Automated licensing

System administrators may need a means to apply the license via the command line. To do this, save the licensing email as a text file, and then pass the text file to CurveExpert Professional on the command line as follows:

> cepro.exe --license the_license_filename.txt --quit

Make sure that you are in the same directory as the executable when running this command, so that the executable can find its required shared libraries. This procedure works under both Mac and Linux; under Linux, simply remove the .exe from the commands above. On macOS, you will have to use the “open” command:

> open /Applications/CurveExpertPro.app --args --license the_license_filename.txt --quit

The application will write a file “license.log” that prints the results of the licensing (success or failure).