CurveExpert Basic 2.1.0 documentation

Miscellaneous

Log Viewer

To view the log files, select Tools->View Logs from the main menu. All logs are stored in the $HOME/.curveexpert-basic/logs directory, and roll according to the preferences that you have set in Edit->Preferences->Logging (see Logging Preferences). So, you can easily view logs for previous sessions of CurveExpert Basic with this tool.

To copy a portion of the log, select the desired portion, and press the Copy button. Likewise, to upload a portion of the log to the CurveExpert Basic server (http://www.curveexpert.net), press the Upload button. Uploading of a log is typically used in conjunction with reporting or tracing a software issue. If no part of the log is selected, the entire log will be copied to clipboard or uploaded, as appropriate.

There is one log file per process that CurveExpert Basic runs. If you are using multicore capability (CurveExpert Pro only), there will be several log files (named worker.n, where n is a number from 0 to the number of helper processes minus one) in addition to the main log file. These worker log files document the actions that each worker has performed, and can be copied or uploaded in identical fashion to the main log.

See Logging Preferences for more detail on configuring the logging options.

_images/logviewer.png

Running Multiple Instances

Running multiple instances of CurveExpert Basic is supported; the only side effect is that, because all instances share the same log files, logging might not function properly.

Where files are located

CurveExpert Basic places files in several locations on disk; the locations are documented below.

Program Files

The default locations are listed below, assuming that the default is accepted during the installation process. If you have changed the location of the program files, obviously they will be placed where you specified.

Platform Program Files Location
Windows (64 bit) c:\Program Files (x86)\CurveExpert Basic
Windows (32 bit) c:\Program Files\CurveExpert Basic

Application Settings

Platform Application Settings Location
Windows in registry: HKEY_CURRENT_USER\Software\CurveExpert Basic

Working/Cache Area

An area is reserved for various caches and items that are needed for normal application operation. This area is used for the cache, logs, and storage of custom user models.

Platform Working/Cache Area Location
Windows $HOME\.curveexpert-basic

CurveExpert Basic Data Files

The data files directory can be customized using Edit->Preferences->General, but the default locations are below. This directory is also where the example data that ships with CurveExpert resides.

Platform Documents Location
Windows $MYDOCUMENTS\CurveExpert Basic